• Hello there guest and welcome to our forum!
    To gain full access you must Register. Registration is free and it takes only a few moments to complete.
    Already a member? Login here then!

Sluggish under WOT

TooMuchBoost

Well-Known Member
Been having some accel issues, going into WOT the car feels abnormally slow and then around 3k rpm the car just falls on it's face as if i just dropped an anchor. after about 5k rpm it seems to clear up a bit but it just doesn't pull as hard anymore.


The car was popping for an internal sum error but it seemed to clear up after i update the firmware on my tuner and reloaded my tunes but the car still feels choppy.

If I'm sitting in neutral and give the car some throttle the idle will dip down around 500 rpm and feel like it's going to stall then recover.

Thought maybe it might be a dirty MAF sensor so i ran some cleaner through it and it didn't seem to do much of anything for me.

I don't know if maybe my tunes are causing this issue or if my PCM is on it's way out or maybe a spark plug?

Anyone have a clue?
 

wickedstangs

Chula Vista, CA
Staff member
Administrator
Been having some accel issues, going into WOT the car feels abnormally slow and then around 3k rpm the car just falls on it's face as if i just dropped an anchor. after about 5k rpm it seems to clear up a bit but it just doesn't pull as hard anymore.


The car was popping for an internal sum error but it seemed to clear up after i update the firmware on my tuner and reloaded my tunes but the car still feels choppy.

If I'm sitting in neutral and give the car some throttle the idle will dip down around 500 rpm and feel like it's going to stall then recover.

Thought maybe it might be a dirty MAF sensor so i ran some cleaner through it and it didn't seem to do much of anything for me.

I don't know if maybe my tunes are causing this issue or if my PCM is on it's way out or maybe a spark plug?

Anyone have a clue?
what all is done to the car?
 
Top